summaryrefslogtreecommitdiff
path: root/hosts/battlestation/configuration.nix
diff options
context:
space:
mode:
authorBenjamin Chausse <benjamin@chausse.xyz>2024-11-14 12:05:09 -0500
committerBenjamin Chausse <benjamin@chausse.xyz>2024-11-14 12:05:09 -0500
commit3727e7bd79fe75ff18b1dc6af494dbda940e0971 (patch)
tree8c4fa53308b74063b4262605a02fcda07cd14d21 /hosts/battlestation/configuration.nix
Batman
Diffstat (limited to 'hosts/battlestation/configuration.nix')
-rw-r--r--hosts/battlestation/configuration.nix155
1 files changed, 155 insertions, 0 deletions
diff --git a/hosts/battlestation/configuration.nix b/hosts/battlestation/configuration.nix
new file mode 100644
index 0000000..e97ee83
--- /dev/null
+++ b/hosts/battlestation/configuration.nix
@@ -0,0 +1,155 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, inputs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ ./hardware-configuration.nix
+ ../../common/main-user.nix
+ ../../common/services.nix
+ ../../software/common.nix
+ ../../software/windowmanager.nix
+ ../../software/entertainment.nix
+ ../../software/development.nix
+ ../../common/dropbox.nix
+ ../../common/ssh.nix
+ ];
+
+ # Bootloader.
+ boot.loader.systemd-boot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+ # boot.kernelParams = ["video=DP-1:3840x2160@60e" "video=DP-2:d"];
+
+ networking.hostName = "battlestation"; # Define your hostname.
+ # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
+
+ nix.settings.experimental-features = [ "nix-command" "flakes" ];
+
+ # Configure network proxy if necessary
+ # networking.proxy.default = "http://user:password@proxy:port/";
+ # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
+
+ # Enable networking
+ networking.networkmanager.enable = true;
+
+ # Set your time zone.
+ time.timeZone = "America/Toronto";
+
+ # Select internationalisation properties.
+ i18n.defaultLocale = "en_CA.UTF-8";
+
+ # Enable the X11 windowing system.
+ # You can disable this if you're only using the Wayland session.
+ services.xserver.enable = true;
+
+ # Enable the KDE Plasma Desktop Environment.
+ # services.displayManager.sddm.enable = true;
+
+ # services.displayManager.ly.enable = true;
+
+ services.greetd = {
+ enable = true;
+ restart = false;
+ settings = {
+ default_session = {
+ command = "${pkgs.greetd.tuigreet}/bin/tuigreet --time --cmd river";
+ user = "master";
+ };
+ initial_session = {
+ command = "river";
+ user = "master";
+ };
+ };
+ };
+
+ services.desktopManager.plasma6.enable = false;
+
+ # Keep shebangs working
+ services.envfs.enable = true;
+
+ # Configure keymap in X11
+ services.xserver.xkb = {
+ layout = "us";
+ variant = "";
+ };
+
+ # Enable CUPS to print documents.
+ services.printing.enable = false;
+
+ # Enable sound with pipewire.
+ hardware.pulseaudio.enable = false;
+ security.rtkit.enable = true;
+ services.pipewire = {
+ enable = true;
+ alsa.enable = true;
+ alsa.support32Bit = true;
+ pulse.enable = true;
+ # If you want to use JACK applications, uncomment this
+ #jack.enable = true;
+
+ # use the example session manager (no others are packaged yet so this is enabled by default,
+ # no need to redefine it in your config for now)
+ # media-session.enable = true;
+ };
+
+ # Enable touchpad support (enabled default in most desktopManager).
+ # services.xserver.libinput.enable = true;
+
+
+main-user.enable = true;
+main-user.userName = "master";
+
+# default shell for all users
+programs.zsh.enable = true;
+users.defaultUserShell = pkgs.zsh;
+
+ # Install firefox.
+ programs.firefox.enable = true;
+
+ # Make neovim default
+ programs.neovim = {
+ enable = true;
+ defaultEditor = true;
+ vimAlias = true;
+ };
+
+ # Allow unfree packages
+ nixpkgs.config.allowUnfree = true;
+
+ # List packages installed in system profile. To search, run:
+ # $ nix search wget
+ environment.systemPackages = with pkgs; [
+ killall
+ neovim
+ zsh
+ # wget
+ ];
+
+ # Some programs need SUID wrappers, can be configured further or are
+ # started in user sessions.
+ # programs.mtr.enable = true;
+ # programs.gnupg.agent = {
+ # enable = true;
+ # enableSSHSupport = true;
+ # };
+
+ # List services that you want to enable:
+
+ # Open ports in the firewall.
+ # networking.firewall.allowedTCPPorts = [ ... ];
+ # networking.firewall.allowedUDPPorts = [ ... ];
+ # Or disable the firewall altogether.
+ # networking.firewall.enable = false;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "24.05"; # Did you read the comment?
+
+}