summaryrefslogtreecommitdiff
path: root/software/common.nix
diff options
context:
space:
mode:
authorBenjamin Chausse <benjamin@chausse.xyz>2024-11-14 12:05:09 -0500
committerBenjamin Chausse <benjamin@chausse.xyz>2024-11-14 12:05:09 -0500
commit3727e7bd79fe75ff18b1dc6af494dbda940e0971 (patch)
tree8c4fa53308b74063b4262605a02fcda07cd14d21 /software/common.nix
Batman
Diffstat (limited to 'software/common.nix')
-rw-r--r--software/common.nix71
1 files changed, 71 insertions, 0 deletions
diff --git a/software/common.nix b/software/common.nix
new file mode 100644
index 0000000..bec9424
--- /dev/null
+++ b/software/common.nix
@@ -0,0 +1,71 @@
+{environment, pkgs, services, programs, ...}:
+
+{
+ environment.systemPackages = with pkgs; [
+ bluetuith
+ zathura
+ firefox
+ mpv
+ imv
+ btop
+ mlocate
+
+ # File Manager and it's preview stuff
+ lf
+ file
+ poppler_utils # for pdftocairo
+ chafa # for sixels
+ lynx # for html
+ imagemagick # for convert
+ ffmpegthumbnailer # for video thumbnails
+ atool # for archives
+ odt2txt # for libreoffice previews
+ xlsx2csv # for excel
+ libwebp # for webp images
+ djvulibre # for dejaVu
+ mediainfo # audio file info
+ bat # cute cat
+
+ # compression/decompression tools
+ zip
+ unzip
+ p7zip
+
+ vesktop # wayland friendly discord client
+
+ obsidian
+ ripgrep
+
+ # Run windows apps with linux
+ winetricks
+ wineWowPackages.staging
+
+ ];
+
+ programs.nix-ld = {
+ enable = true;
+ libraries = with pkgs; [
+
+ # Needed for scarlett-mixer
+ pango
+ cairo
+ glib
+ gtk4
+ gtk3
+ dbus-glib
+ gobject-introspection
+ harfbuzz
+ libGL
+ libGLU
+ alsa-lib
+ xorg.libX11
+
+ ];
+ };
+ services.pcscd.enable = true;
+ programs.gnupg.agent = {
+ enable = true;
+ enableSSHSupport = true;
+ };
+
+}