summaryrefslogtreecommitdiff
path: root/software/windowmanager.nix
diff options
context:
space:
mode:
authorBenjamin Chausse <benjamin@chausse.xyz>2024-11-22 03:29:56 -0500
committerBenjamin Chausse <benjamin@chausse.xyz>2024-11-22 03:29:56 -0500
commit90854019fc940473a0ce4fff29c402e54841f704 (patch)
treeb7eb2a97dbdbfe151ff77a23c1b54a2399dbe311 /software/windowmanager.nix
parent3727e7bd79fe75ff18b1dc6af494dbda940e0971 (diff)
Another day
Diffstat (limited to 'software/windowmanager.nix')
-rw-r--r--software/windowmanager.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/software/windowmanager.nix b/software/windowmanager.nix
index d43b9fe..c89913b 100644
--- a/software/windowmanager.nix
+++ b/software/windowmanager.nix
@@ -40,7 +40,7 @@
playerctl # control next/previous song
glib # for gdbus needed by volumectl
];
-
+
# Screen capture/sharing:
xdg.portal = {
enable = true;
@@ -65,4 +65,22 @@
# Force wayland on electron
environment.sessionVariables.NIXOS_OZONE_WL = "1";
+ # Trigger updates to waybar
+ services.cron = {
+ enable = true;
+ systemCronJobs = [
+ # Time & Date
+ "* * * * * kill -42 $(pidof waybar)"
+ "* * * * * kill -40 $(pidof waybar)"
+ # Battery
+ "* * * * * kill -35 $(pidof waybar)"
+ # Yadm Dotfiles
+ "*/10 * * * * kill -41 $(pidof waybar)"
+ # Emails
+ "*/5 * * * * kill -46 $(pidof waybar)"
+ # Gentoo News
+ "*/30 * * * * kill -45 $(pidof waybar)"
+ ];
+ };
+
}