summaryrefslogtreecommitdiff
path: root/common/main-user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/main-user.nix')
-rw-r--r--common/main-user.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/common/main-user.nix b/common/main-user.nix
new file mode 100644
index 0000000..4219b67
--- /dev/null
+++ b/common/main-user.nix
@@ -0,0 +1,44 @@
+{lib, config, pkgs, programs, environment, ...}:
+
+let
+ cfg = config.main-user;
+in
+{
+
+ options.main-user = {
+ enable = lib.mkEnableOption "enable user module";
+ userName = lib.mkOption {
+ default = "master";
+ description = ''
+ username
+ '';
+ };
+ };
+
+ config = lib.mkIf config.main-user.enable {
+
+
+ programs.zsh.enable = true;
+
+ users.groups.plugdev = {};
+ users.users.${config.main-user.userName} = {
+ isNormalUser = true;
+ initialPassword = "password1324";
+ description = "Benjamin Chausse";
+ group = "wheel";
+ extraGroups = ["plugdev" "networkmanager" "docker" "mlocate"];
+ shell = pkgs.zsh;
+ };
+
+ environment.systemPackages = with pkgs; [
+ git
+ yadm
+ neovim
+ zsh
+ zsh-syntax-highlighting
+ ];
+
+ };
+}
+
+