summaryrefslogtreecommitdiff
path: root/common/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/ssh.nix')
-rw-r--r--common/ssh.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/common/ssh.nix b/common/ssh.nix
new file mode 100644
index 0000000..de931f5
--- /dev/null
+++ b/common/ssh.nix
@@ -0,0 +1,16 @@
+{services, networking, ...}:
+
+{
+ services.openssh = {
+ enable = true;
+ ports = [ 22 ];
+ settings = {
+ PasswordAuthentication = true;
+ AllowUsers = null; # Allows all users by default. Can be [ "user1" "user2" ]
+ UseDns = true;
+ X11Forwarding = false;
+ PermitRootLogin = "no"; # "yes", "without-password", "prohibit-password", "forced-commands-only", "no"
+ };
+ };
+ # networking.firewall.allowedTCPPorts = [22];
+}