summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..f307af3
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,32 @@
+{
+ description = "Nixos config flake";
+
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+
+ # home-manager = {
+ # url = "github:nix-community/home-manager";
+ # inputs.nixpkgs.follows = "nixpkgs";
+ # };
+ xremap-flake.url = "github:xremap/nix-flake";
+ };
+
+ outputs = { self, nixpkgs, ... }@inputs: {
+ nixosConfigurations = {
+ battlestation = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs;};
+ modules = [
+ ./hosts/battlestation/configuration.nix
+ # inputs.home-manager.nixosModules.default
+ ];
+ };
+ laptop = nixpkgs.lib.nixosSystem {
+ specialArgs = {inherit inputs;};
+ modules = [
+ ./hosts/laptop/configuration.nix
+ # inputs.home-manager.nixosModules.default
+ ];
+ };
+ };
+ };
+}