summaryrefslogtreecommitdiff
path: root/hosts/battlestation/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/battlestation/hardware-configuration.nix')
-rw-r--r--hosts/battlestation/hardware-configuration.nix92
1 files changed, 92 insertions, 0 deletions
diff --git a/hosts/battlestation/hardware-configuration.nix b/hosts/battlestation/hardware-configuration.nix
new file mode 100644
index 0000000..ed28aa5
--- /dev/null
+++ b/hosts/battlestation/hardware-configuration.nix
@@ -0,0 +1,92 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ virtualisation, config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usbhid" "usb_storage" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/957b4b6c-f5cc-43bf-9afd-f801a8af7f3a";
+ fsType = "btrfs";
+ options = [ "subvol=@" ];
+ };
+
+ "/boot" = {
+ device = "/dev/disk/by-uuid/42C6-5222";
+ fsType = "vfat";
+ options = [ "fmask=0077" "dmask=0077" ];
+ };
+ "/games" = {
+ device = "/dev/disk/by-uuid/430933bb-e59a-4b17-9b93-7fbd6be0c4f9";
+ fsType = "ext4";
+ };
+ "/vault" = {
+ device = "/dev/disk/by-uuid/0b5fd130-25ef-4839-858a-5f1ddeeb4b9b";
+ fsType = "ext4";
+ };
+ "/music" = {
+ device = "/dev/disk/by-uuid/5EA2937CA293577D";
+ fsType = "ntfs-3g";
+ options = [ "rw" "uid=1000" ];
+ };
+ "/wingames" = {
+ device = "/dev/disk/by-uuid/209EC7D39EC7A020";
+ fsType = "ntfs-3g";
+ options = [ "rw" "uid=1000" ];
+ };
+ "/nvme" = {
+ device = "/dev/disk/by-uuid/880751ef-378e-45e4-892a-1086bb2be140";
+ fsType = "ext4";
+ };
+ };
+
+ swapDevices = [ ];
+
+ # Make docker work on "/"
+ virtualisation.docker.storageDriver = "btrfs";
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlp4s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware = {
+ cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+ graphics.enable = true;
+ nvidia = {
+ modesetting.enable = true;
+ powerManagement.enable = false;
+ powerManagement.finegrained = false;
+ open = true;
+ nvidiaSettings = true;
+ };
+
+ bluetooth.enable = true;
+ bluetooth.powerOnBoot = true;
+
+ };
+ services.xserver.videoDrivers = ["nvidia"];
+
+ environment.systemPackages = with pkgs; [
+ openrgb
+ ];
+ services.hardware.openrgb = {
+ enable = true;
+ package = pkgs.openrgb;
+ motherboard = "intel";
+ };
+
+}