summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryusufaktepe <yusuf@yusufaktepe.com>2019-05-08 04:05:57 +0300
committeryusufaktepe <yusuf@yusufaktepe.com>2019-05-08 04:05:57 +0300
commit3cd91894ec91a0de7aa71d62949ba3381e600afd (patch)
treeb20ec7e05d5970bdfc7c35bfbf9c89b7541b011b /PKGBUILD
parent35506b44adf9176062f2cc51bcfd54ac79246744 (diff)
Updated st to 0.8.2
Updated to latest git (20190414.f1546cf) & updated patches. Changes: . Upstream fixes. . Alpha: Opacity value is now typed in float (0-1). Also "-A" cmd option added as alternative opacity changing method. . Clipboard: middle click pastes from clipboard. . Organized shortcuts.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 959a2e9..ebafe00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
pkgname=st-luke-git
_pkgname=st
-_pkgver=0.8.1
-pkgver=0.8.1.r1046.1cd0b79
+_pkgver=0.8.2
+pkgver=0.8.2.r1059.51ac1b9
pkgrel=1
+epoch=1
pkgdesc="Luke's simple (suckless) terminal with vim-bindings, transparency, xresources, etc. "
url='https://github.com/LukeSmithxyz/st'
arch=('i686' 'x86_64')
@@ -21,12 +22,12 @@ conflicts=("${_pkgname}")
pkgver() {
cd "${_pkgname}"
- printf "${_pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd $srcdir/${_pkgname}
- # skip terminfo which conflicts with nsurses
+ # skip terminfo which conflicts with ncurses
sed -i '/tic /d' Makefile
}
@@ -40,4 +41,5 @@ package() {
make PREFIX=/usr DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 .Xdefaults "${pkgdir}/usr/share/doc/${pkgname}/Xdefaults.example"
}