summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorWez Furlong <wez@wezfurlong.org>2024-05-05 22:28:55 -0700
committerWez Furlong <wez@wezfurlong.org>2024-05-05 22:29:32 -0700
commit1ba5a6085270ccdb067d63e0cb436fc148a99809 (patch)
treee93fef38ccd20c2a4d0e4c1ef30d17b91b73bc55 /Cargo.toml
parenta2b29dd6d37dfa00c26718d6e015b63133d981c4 (diff)
update deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8761c63..6facc72 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,15 +2,15 @@
name = "evremap"
version = "0.1.0"
authors = ["Wez Furlong"]
-edition = "2018"
+edition = "2021"
[dependencies]
-evdev-rs = "0.6.1"
anyhow = "1.0"
+clap = {version="4.5", features=["derive"]}
+evdev-rs = "0.6.1"
+libc = "0.2"
log = "0.4"
-pretty_env_logger = "0.3"
-structopt = "0.3"
+pretty_env_logger = "0.5"
serde = { version="1.0", features=["derive"]}
thiserror = "1.0"
-toml = "0.5"
-libc = "0.2"
+toml = "0.8"