summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8761c63..6facc72 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,15 +2,15 @@
name = "evremap"
version = "0.1.0"
authors = ["Wez Furlong"]
-edition = "2018"
+edition = "2021"
[dependencies]
-evdev-rs = "0.6.1"
anyhow = "1.0"
+clap = {version="4.5", features=["derive"]}
+evdev-rs = "0.6.1"
+libc = "0.2"
log = "0.4"
-pretty_env_logger = "0.3"
-structopt = "0.3"
+pretty_env_logger = "0.5"
serde = { version="1.0", features=["derive"]}
thiserror = "1.0"
-toml = "0.5"
-libc = "0.2"
+toml = "0.8"