summaryrefslogtreecommitdiff
path: root/common/services.nix
diff options
context:
space:
mode:
authorBenjamin Chausse <benjamin@chausse.xyz>2024-11-14 12:05:09 -0500
committerBenjamin Chausse <benjamin@chausse.xyz>2024-11-14 12:05:09 -0500
commit3727e7bd79fe75ff18b1dc6af494dbda940e0971 (patch)
tree8c4fa53308b74063b4262605a02fcda07cd14d21 /common/services.nix
Batman
Diffstat (limited to 'common/services.nix')
-rw-r--r--common/services.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/common/services.nix b/common/services.nix
new file mode 100644
index 0000000..7ed9bec
--- /dev/null
+++ b/common/services.nix
@@ -0,0 +1,18 @@
+{virtualisation, environment, pkgs, services, ...}:
+
+{
+ virtualisation.docker = {
+ enable = true;
+ liveRestore = false;
+ };
+ environment.systemPackages = with pkgs; [
+ lazydocker
+ ];
+
+ services.plex = {
+ enable = true;
+ openFirewall = true;
+ user="master";
+ accelerationDevices = ["*"];
+ };
+}