summaryrefslogtreecommitdiff
path: root/common/services.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/services.nix')
-rw-r--r--common/services.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/common/services.nix b/common/services.nix
new file mode 100644
index 0000000..7ed9bec
--- /dev/null
+++ b/common/services.nix
@@ -0,0 +1,18 @@
+{virtualisation, environment, pkgs, services, ...}:
+
+{
+ virtualisation.docker = {
+ enable = true;
+ liveRestore = false;
+ };
+ environment.systemPackages = with pkgs; [
+ lazydocker
+ ];
+
+ services.plex = {
+ enable = true;
+ openFirewall = true;
+ user="master";
+ accelerationDevices = ["*"];
+ };
+}